KilometerMagazine.com - A6 c6 immobilizer controller doesn't respond or vcds stops responding
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Results 1 to 2 of 2
    1. 02-13-2017 02:49 PM #1
      I own a A6 c6 3.2 avant Quattro. For some reason I have been getting an immobilizer code but when I try to access the controller it either says it's not responding or my vcds problem stops responding when trying to access the controller. First question, is my immobilizer controller in the dash or ECM? Second question, if there is a short in my ECM would it also effect other controllers like my evap system? Reason I ask is bc I keep getting an implausible signal p2404 evap code even after replace purge valve, gas cap, LDP and passing a smoke test. Any and all help/info is greatly appreciated. Thanks

      Sent from my XT1585 using Tapatalk

    2. 04-12-2017 08:21 AM #2
      Its been a long time since Ive been an audi mechanic but I would think it could be the immobilizer or the gateway. Check your fuses. I know that sounds like a stupid simple thing but it could be the issue. I hope its not the unit its self. I know in the c5 it was some deal in the center console uder the dash. I doubt the ecm is fried. that usually leads to way bigger problems. VCDS failure makes me think its a fuse or corrosion in a connection. I keep re reading your post and It sounds like a fuse or a connection. The worst situation could be moisture. Check around the ECM

    For advertising information click HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •