KilometerMagazine.com - Air flow meter problems
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Results 1 to 3 of 3
    1. Semi-n00b
      Join Date
      Feb 20th, 2012
      Location
      council bluffs ia
      Posts
      18
      03-16-2017 10:12 AM #1
      Hey guys so I just replaced my fuel pump, fuel filter, in tank fuel pump and fuel tank. I made sure everything is working properly I am getting pressure to the injectors when I lift the air flow plunger in the fuel distributor assembly. What's weird is it ran fine after I replaced all that stuff then I let it get warm and shut it off and replaced a stereo fuse. Went to turn the car back on and it ran horrible. Idles at around 200 rpm and will not excelerate if I give it gas it dies. So I'm not sure if it could be my ecu gone bad or what. Any help would be greatly appreciated.

    2. Semi-n00b
      Join Date
      Feb 20th, 2012
      Location
      council bluffs ia
      Posts
      18
      03-16-2017 10:12 AM #2
      It's for an 89 fox wagon by the way

    3. Member
      Join Date
      Feb 16th, 2013
      Location
      baltimore maryland
      Posts
      222
      Vehicles
      1988 fox wagon, (past 85 volvo turbo)
      03-19-2017 09:01 AM #3
      pull out the injectors and make sure thay are all squirting

    For advertising information click HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •