KilometerMagazine.com - Intermittent Gas Cap Light
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Results 1 to 8 of 8
    1. Junior Member
      Join Date
      May 19th, 2009
      Location
      NYC
      Posts
      94
      Vehicles
      2008 Candy White Wagon FSI
      03-20-2017 01:19 PM #1
      Hi,

      I have a 2008 FSI Wagon (with about 55K) and for the past 3-4 months I've been having Gas Cap Light popping up once or twice a month. The light goes away if I drive for a a bit (at least 10-15 minutes) shut the engine off and start the car again but it doesn't go away if I turn the car off immediately and tighten the gas cap. I drive mostly on weekends, so it may be affecting the frequency. Thoughts? (I haven't had the codes checked but plan on asking the shop I go to when I go for spring check up)

      Thank you.

    2. Member Soundwave_vr6's Avatar
      Join Date
      Sep 30th, 2007
      Location
      Ontario
      Posts
      7,690
      Vehicles
      3.6 4mo
      03-20-2017 04:50 PM #2
      take a look at the o ring on the cap. if its all cracked get a new cap.

    3. 03-20-2017 08:37 PM #3
      Could be N80 valve. I was having the gas cap fault so I replace my N80 valve. Hasn't been back since.

    4. Junior Member
      Join Date
      May 19th, 2009
      Location
      NYC
      Posts
      94
      Vehicles
      2008 Candy White Wagon FSI
      03-21-2017 09:26 AM #4
      Thank you.

    5. Member
      Join Date
      May 15th, 2012
      Location
      LA
      Posts
      186
      Vehicles
      01 FrankenGTI, 12 Tiglean (wife) 08 r36'ish ;-)
      03-21-2017 10:30 AM #5
      I didn't have a dash light but the evap system kept showing up in the VCDS scans.. Bought a new gas cap and lost it in the move (it's packed somewhere) so changed the n80 valve while looking for that ____ gas cap. No issues since.

    6. Member 10001110101's Avatar
      Join Date
      Aug 7th, 2007
      Location
      Monticello, MN
      Posts
      402
      Vehicles
      B6 Lux Wagon, 2010 F-Juan Fitty
      03-21-2017 01:11 PM #6
      Thirded on the N80 valve. I changed my gas cap first and it did not fix the problem. N80 changed in 10 minutes and no light since.

    7. Junior Member
      Join Date
      May 19th, 2009
      Location
      NYC
      Posts
      94
      Vehicles
      2008 Candy White Wagon FSI
      04-12-2017 09:37 AM #7
      Confirmed, it was N80 valve. A CEL popped up over the weekend which also was caused by the valve.

      Thank you, all.

    8. Member Soundwave_vr6's Avatar
      Join Date
      Sep 30th, 2007
      Location
      Ontario
      Posts
      7,690
      Vehicles
      3.6 4mo
      04-13-2017 07:42 AM #8
      already replaced cap. new n80 on its way today. hope to have same luck as everyone else.

      tired of random check engine lights

    For advertising information click HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •