KilometerMagazine.com - New turbo, days later underboost code
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Results 1 to 9 of 9
    1. 04-05-2017 06:30 PM #1
      07 GTI - had the dealer replace the turbo due to requiring to fix the CEL for end of march PA state emissions inspection. The codes were fuel too lean and underboost. For months now the turbo was noisy at and past 3000 rpms. It was found the shaft and bearing had play in it and that was the cause. Replaced turbo codes went away and passed inspection. Days later the fuel too lean code came back. Had an independent shop do timing belt and replace brake booster cable, codes gone. They noted I had a pending code for underboost and if it comes on they can diagnose it. A day later CEL comes on and I check and its p0299 underboost.

      The dealer warranties all parts and labor for 1 year. I can take it there and hopefully it's covered in full. I spent enough on this car in the last few weeks I'm about ready to sell it for something with 4 doors instead of two.

      What do you think the underboost is from? Something come loose from the install? They get a faulty part? Trust the dealer or take it back to the independent shop?

      Dealer pros:
      Nice loaner cars - don't have to take time off work.
      Long hours
      Warrantied parts and labor
      Honors Extended warranties (they did my HPFP / cam / follower for free)

      Independent German car shop pros:
      Closer to home
      About half price for everything (timing belt was half price what the dealer quoted).

    2. 04-06-2017 09:47 AM #2
      Take it back to the dealer. They installed the turbo so they should diagnose it and make it right if its a faulty part or if they did not install properly.

    3. 04-06-2017 09:20 PM #3
      Quote Originally Posted by _Riddle View Post
      Take it back to the dealer. They installed the turbo so they should diagnose it and make it right if its a faulty part or if they did not install properly.

      That's what I'm going to do. I am on the books for next week. Hope all goes well and I don't have to lay out any more money.

    4. 04-13-2017 02:31 PM #4
      Good advice going to the dealer. Fixed for free. The diverter valve that came with the new turbo basically "fell apart". When they took it off to diagnose it. So they replaced that and tested out to be fine. Since it was part of the original repair, it's warrantied parts and labor for a year. Meanwhile I get to drive around a pretty well equipped brand new VW CC for the day until I get out that way to pick up the car.

    5. 04-21-2017 08:01 AM #5
      That diverter valve was replaced but code came right back. They smoke tested the system and found a major leak at the intercooler, passenger side. They replaced the intercooler for a reduced price due to all the money and downtime I've been dealing with.

      Got it home Wednesday night and the underboost code is back! I cleared it twice already but it keeps coming back, first as a pending code, then eventually throws a CEL. Car does feel much better since the intercooler swap. What could be the cause of the underboost code now?
      New turbo, new DV, new intercooler....

      They even drove it for 30 miles after replacing the intercooler. I guess they don't drive it as hard as I do.

    6. 04-21-2017 09:35 AM #6
      Did they smoke test again after changing the intercooler?

    7. 04-21-2017 11:22 AM #7
      Quote Originally Posted by _Riddle View Post
      Did they smoke test again after changing the intercooler?
      I don't have the paperwork on me right now but I don't recall it mentioning it.

      Here's my theory. First the turbo was on its way out for a long time. The noise became louder over time. Needed inspection so to pass emissions we have to resolve everything that throws a CEL. Turbo replaced, was smoke tested then. A few days later CEL appeared again for underboost. Now I think when I hit a deer two years ago it may have weakened the intercooler, but maybe the new turbo was boosting higher and any hairline cracks or fractures in the plastic ends of the intercooler busted open.

      But the quick and dirty thing to check is the DV. So they did that and the piston fell right out. It came with the new turbo so they fixed it for free. Drive it out and instant CEL. Then they smoke test and found the intercooler leak.

      But nowhere does it say they smoke tested again. They did say they drove it 30 miles. Well it's not their car, they probably took it easy. I drive pretty spirited and I can get the code to come up in 20 miles after a reset.

    8. 04-22-2017 04:33 AM #8
      N75 or some of the vaccum pipes at the n75

    9. 04-22-2017 07:20 PM #9
      Quote Originally Posted by madeindk View Post
      N75 or some of the vaccum pipes at the n75
      I also just developed system too lean bank 1 code. I had the brake booster cables replaced and that fixed that code for a few weeks, but now it's back. I am just disappointed in this car, and the fact that I have to keep taking it back to the dealer to get fixed. At what point do I say F them, it never comes back fixed and go somewhere else? My only saving grace could be that the turbo they put in came with whatever is wrong, so that it can be fixed for free. Otherwise I really can't afford to keep dumping money in the car. I'm about ready to clear the code myself and sell it or trade it in on a Mazda or Nissan.

    For advertising information click HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •