KilometerMagazine.com - Light Assist enabled, apparently not working
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Results 1 to 12 of 12
    1. Member KevinC's Avatar
      Join Date
      Feb 16th, 1999
      Location
      Chandler, AZ
      Posts
      9,632
      Vehicles
      '16 Golf R, '05 E46 330Ci ZHP
      04-21-2017 12:41 PM #1
      I've enabled Light Assist (or High Beam Assist, whatever the proper term is) on my '16 via OBDeleven. It shows up properly in my lighting menu, and the proper symbol lights up in the center display when enabled. But - it doesn't seem to be working, the high beams have yet to illuminate on their own, even at speed and on a very dark and long street. I thought maybe I had a problem with the camera, but lane assist works fine and there are no codes being thrown, so I don't think that's an issue.

      Any idea what could be up? I got to use this feature for the first time on our new Mazda3 last weekend, and it was incredible, especially since we were in a very dark corner of rural southern Arizona. Need to get the R working properly. Any advice appreciated.

      '05 E46 330Ci ZHP coupé ..PD99819
      '16 Golf R 6MT/DCC/DAP

    2. Semi-n00b deathmonkey's Avatar
      Join Date
      Apr 17th, 2017
      Location
      Chicagoland, IL
      Posts
      15
      Vehicles
      2017 Golf R DSG w/DCC
      04-21-2017 12:52 PM #2
      Quote Originally Posted by KevinC View Post
      I've enabled Light Assist (or High Beam Assist, whatever the proper term is) on my '16 via OBDeleven. It shows up properly in my lighting menu, and the proper symbol lights up in the center display when enabled. But - it doesn't seem to be working, the high beams have yet to illuminate on their own, even at speed and on a very dark and long street. I thought maybe I had a problem with the camera, but lane assist works fine and there are no codes being thrown, so I don't think that's an issue.

      Any idea what could be up? I got to use this feature for the first time on our new Mazda3 last weekend, and it was incredible, especially since we were in a very dark corner of rural southern Arizona. Need to get the R working properly. Any advice appreciated.
      Did you do the reset through the touch screen? I know for some things to take effect, you need to do the reset first, even if the option you coded is showing up under the submenu.

    3. Member
      Join Date
      Feb 8th, 2017
      Location
      Calgary, AB, Canada
      Posts
      188
      Vehicles
      2017 Golf R, LG, DSG, Tech Pack
      04-21-2017 12:58 PM #3
      I'm curious why you would even need to use the OBDeleven for this? Can't you enable this through touch screen?

    4. Member
      Join Date
      Jun 8th, 2016
      Location
      Calgary, Alberta
      Posts
      256
      Vehicles
      2016 Golf R
      04-21-2017 01:15 PM #4
      Quote Originally Posted by supesgolfr View Post
      I'm curious why you would even need to use the OBDeleven for this? Can't you enable this through touch screen?
      Not on a 2016 model as the feature was not enabled from the factory.

    5. Junior Member
      Join Date
      Dec 9th, 2015
      Location
      Wisconsin
      Posts
      50
      Vehicles
      2017 Golf R Oryx White Pearl DSG
      04-21-2017 01:17 PM #5
      From my experience;

      If the headlight switch is set to "ON", the light assist will not operate.

      The headlight switch needs to be in the "AUTO" setting for the automatic high beams to operate.

    6. Member Golf R MK7's Avatar
      Join Date
      Dec 14th, 2015
      Posts
      165
      Vehicles
      2016 Golf R DSG
      04-21-2017 02:26 PM #6
      I have it enabled on my 2016 and it doesn't come on as often as I'd like. I did discover a sensitivity setting in the menu (thinking two choices?) but that adjustment didn't have a noticeable effect.

    7. Member
      Join Date
      Jun 8th, 2016
      Location
      Calgary, Alberta
      Posts
      256
      Vehicles
      2016 Golf R
      04-21-2017 03:05 PM #7
      Quote Originally Posted by Golf R MK7 View Post
      I have it enabled on my 2016 and it doesn't come on as often as I'd like. I did discover a sensitivity setting in the menu (thinking two choices?) but that adjustment didn't have a noticeable effect.
      I've been too lazy to program mine so I can't comment on the effectiveness but is there any difference in hardware for the 2016 as opposed to the 2017 models in regards to the high beam assist? Not exactly sure why it wasn't enabled for 2016 cars.

    8. Member demented_irony's Avatar
      Join Date
      Apr 25th, 2007
      Location
      Vancouver, BC
      Posts
      556
      Vehicles
      2016 Golf R, 2001 Audi A6 2.7TT 6MT, 2006 Touareg V8, 81 Rabbit S 16v
      04-21-2017 05:31 PM #8
      Headlight switch must be in "auto". There's several adaption channels to configure highbeam assist. Minimum speed to turn on, turn off, minimum darkness to turn on and off, and delay for turning on and off. I can't remember my settings off hand, but I've got it adjusted damn near perfectly for my liking. I'll post up my details later.

    9. 04-21-2017 06:24 PM #9
      Found this, does it help? :

      Quote Originally Posted by vqv View Post
      VW did not enable Light Assist (automatic high beam control) on DAP equipped GSW until model year 2017. So I enabled it on my 2016 with VCDS using the instructions here and here.




      With Light Assist enabled, when you push forward on the signal stalk to toggle the high beams, the high beam icon with an 'A' in the middle appears in the MFD. Looks like it should function, but I haven't had a chance to go for a night drive outside the city yet.

    10. Member isoprene's Avatar
      Join Date
      Jul 5th, 2007
      Location
      Western Canada
      Posts
      4,009
      Vehicles
      2016 Golf R Tech/DSG
      04-21-2017 06:26 PM #10
      Quote Originally Posted by demented_irony View Post
      There's several adaption channels to configure highbeam assist. Minimum speed to turn on, turn off, minimum darkness to turn on and off, and delay for turning on and off.
      That's good to know. I find the OFF delay to be perfect but ON is too slow after an oncoming car passes me.

    11. Member Golf R MK7's Avatar
      Join Date
      Dec 14th, 2015
      Posts
      165
      Vehicles
      2016 Golf R DSG
      04-21-2017 08:03 PM #11
      Quote Originally Posted by heavyD^2 View Post
      I've been too lazy to program mine so I can't comment on the effectiveness but is there any difference in hardware for the 2016 as opposed to the 2017 models in regards to the high beam assist? Not exactly sure why it wasn't enabled for 2016 cars.
      Good question, I'd guess the hardware to be identical.

    12. Member KevinC's Avatar
      Join Date
      Feb 16th, 1999
      Location
      Chandler, AZ
      Posts
      9,632
      Vehicles
      '16 Golf R, '05 E46 330Ci ZHP
      Yesterday 04:49 PM #12
      Thanks for all the helpful suggestions. Light Assist was of course enabled in the setup menu, otherwise I wouldn't even get the symbol in the cluster when turning it on via the high beam stalk. Also I am only attempting to use it with the light switch in auto position, so that's not the problem.

      The "turn-on time" option was set at medium - though I'm not sure this is even for HBA, might just be for the auto headlights? Not clear after deciding to RTFM on the topic. I changed it to "early" (or whatever that option is called) to see if that has any effect. I also rebooted the head unit just for kicks.

      Will update soon with results, if any.

      '05 E46 330Ci ZHP coupé ..PD99819
      '16 Golf R 6MT/DCC/DAP

    For advertising information click HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •